SIU-Arai/Requerimientos

De SIU
Saltar a: navegación, buscar
Siu-arai iso.png


Requerimientos técnicos de la plataforma

A continuación se detallan los requerimientos de software para el despliegue básico de SIU-Araí y sus componentes.

Requerimiento del Sistema Operativo

El desarrollo, pruebas y despliegue de toda la plataforma se ha realizado con los sistemas operativos de base Linux que abajo se detallan. Otros pueden funcionar, pero no se dan garantías de ello.

S.O PHP nativo Sodium nativo PostgreSQL nativo
Debian Jessie 8 no 1 si no 2
Debian Stretch 9 si si si
Ubuntu 16.04 ? si no 2
Ubunto 18.04 - - -

Leyendas:

( - ) todavía no se encuentra liberada una versión que lo soporte

( ? ) no se ha probado su integración con la plataforma

( 1 ) requiere paquetes PHP extra-oficiales

( 2 ) requiere paquetes PostgreSQL extra-oficiales

Requerimientos del servidor de aplicaciones

PHP PHP libsodium1 Sodium en S.O. Apache Librería arai-cli SIU-Araí: Registry SIU-Araí: Usuarios SIU-Huarpe
7.2 ? ? 2.4.x - - - -
7.1 1.0.6 a 1.0.7 1.0.6 o superior 2.3.0 a 2.5.x 2.0.0 a 2.1.x 2.1.x 2.1.x
7.0 2.0.x 2.0.x
5.6 a 7.1 x x 2.2.x a 2.4.x 1.0.0 a 2.2.0 1.0.0 a 1.1.2 1.x.x 1.0.0 a 1.1.5
Leyendas:

( x.x.x ) se ha probado su integración en dicha versión

( x ) no requerido

( - ) todavía no se encuentra liberada una versión que lo soporte

( ? ) no se ha probado su integración con la plataforma

( 1 ) ver la documentación específica al respecto sobre Sodium

Requerimientos del servidor de Base de Datos

PostgreSQL SIU-Araí: Registry SIU-Araí: Usuarios SIU-Huarpe
10.0.x 2.1.x 2.1.x x
9.4.x a 9.6.x 2.0.0 a 2.1.x 2.0.x 2.1.x
1.0.0 a 1.1.2 1.x.x
Leyendas:

( x.x.x ) se ha probado su integración en dicha versión

( x ) no requerido

( - ) todavía no se encuentra liberada una versión que lo soporte

( ? ) no se ha probado su integración con la plataforma

< Volver