SIU-Guarani/version3.18.0/instalacion desde cero/requisitos previos/linux

De SIU
(Redirigido desde «SIU-Guarani/Version3.18.0/instalacion desde cero/requisitos previos/linux»)
Saltar a: navegación, buscar

Requisitos previos para la instalación en Linux – Distribuciones Debian o derivados

Versiones requeridas

A continuación listamos las versiones requeridas para un correcto funcionamiento del sistema:

Apache 2.2.x o 2.4.x
PHP 7.3.x
PostgreSQL 11.6.x
yui-compressor 2.4.2 o superior
Yarn 1.19.1 o superior
Composer 1.x.x (no instalar Composer 2)

Nuevos requisitos técnicos de la versión 3.18

  • Tener composer instalado. Para verificarlo, se puede correr el siguiente comando y verificar que no dé error:
composer --version
En caso de no estar instalado, seguir las intrucciones especificadas en el paso 6
  • Tener Yarn instalado. Para verificarlo, se puede correr el siguiente comando y verificar que no dé error:
yarn --version
En caso de no estar instalado, seguir las instrucciones especificadas en el paso 7

Instalación

  1. Apache
    1. Ejecutar como superusuario:
      apt-get install apache2 libapache2-mod-php7.3 openssl
    2. Habilitar los módulos:
      • rewrite_module
      • setenvif_module
      Para ello, ejecutar:
      a2enmod rewrite
      a2enmod setenvif
  2. PHP
    1. En caso de que los repositorios no tengan una versión actualizada de PHP, cambiar las fuentes de los paquetes.
      Ejecutar como superusuario:
      apt-get install php7.3-cli php7.3-pgsql php7.3-gd php7.3-curl php-apcu php7.3-mbstring php7.3-xml php7.3-zip php-libsodium
      Si se utiliza el manejador de cache Memcached ejecutar:
      apt-get install php-memcached
    2. Para verificar que se hayan instalado los paquetes adecuadamente, ejecutar:
      php -m
      En caso de no encontrar los paquetes pdo y pdo_pgsql en el listado, se necesita instalarlos manualmente. Para ello hay que descargar y compilar las extensiones utilizando el comando pecl:
       apt-get install php7.3-dev php-pear postgresql-server-dev-11 build-essential
       pecl install pdo
       pecl install pdo_pgsql
    3. Agregar a los archivos '/etc/php/7.3/cli/php.ini' y '/etc/php/7.3/apache2/php.ini':
       extension=pdo.so  
       extension=pdo_pgsql.so
      Configurar además en los archivos mencionados previamente:
       ;Mínimos
       output_buffering = On  

       ;Recomendados  
       memory_limit = 256M  
       upload_max_filesize = 8M
       post_max_size = 8M
       date.timezone = America/Argentina/Buenos_Aires
       default_charset = "ISO-8859-1"
       mbstring.internal_encoding = "ISO-8859-1"
      • upload_max_filesize: Indica el tamaño máximo del archivo, esto en el sentido de si graba o no.
      • post_max_size: Indica el máximo tamaño que el PHP aceptará para el POST. Sería recomendable que sea mayor a 'upload_max_filesize' porque los mensajes de error sobre el tamaño del archivo se muestran siempre que este tamaño esté entre 'upload_max_filesize' y 'post_max_size'
      En caso de que los parámetros mencionados previamente no se encuentren en el archivo, agregarlos con la configuración indicada.
      Reiniciar Apache:
      sudo service apache2 restart
  3. PostgreSQL
    En caso de no contar con un servidor aparte, ejecutar:
     apt-get install postgresql
     apt-get install postgresql-contrib-11
    Se sugiere inicializar el cluster y crear la base de datos con encoding UTF8
    La base de datos de negocio de SIU-Guaraní debe estar en la misma base de datos que la instancia Toba, dentro de un esquema diferente (usualmente 'negocio' y 'desarrollo', respectivamente)
    Asegurarse que en el archivo postgresql.conf
    • la variable standard_conforming_strings esté seteada con valor off y que la misma NO esté comentada
    • la variable bytea_output esté seteada con valor escape y que la misma NO esté comentada
    • la variable timezone esté correctamente configurada
    Reiniciar Postgres:
    sudo service postgresql restart
  4. Subversion
    apt-get install subversion
  5. Git (versión 2 o mayor)
    apt-get install git
  6. Composer
    Descargar Composer
    Instalarlo globalmente
    Para que Composer funcione correctamente se deben instalar los paquetes zip y unzip:
    sudo apt-get install zip
    sudo apt-get install unzip
  7. Yarn
    Instalarlo desde aquí
  8. Graphviz
    apt-get install graphviz
  9. Java
    sudo apt-get install default-jdk
  10. Suhosin
    Si tiene habilitado el sistema de protección Suhosin deberá configurar los siguientes parámetros (generalmente en '/etc/php/7.3/conf.d/suhosin.ini'):
     suhosin.request.max_varname_length = 128  
     suhosin.post.max_name_length = 128