SIU-Guarani/Version3.20.0/Novedades tecnicas

De SIU
Revisión del 16:59 14 jun 2022 de Lleonardis (discusión | contribuciones)
(dif) ← Revisión anterior | Revisión actual (dif) | Revisión siguiente → (dif)
Saltar a: navegación, buscar


Principales novedades técnicas

Volver

Número de versión: 3.20.2

Fecha de publicación: 15/06/2022

Diferencias con versiones anteriores

API-REST Guaraní

Gestión

  • Se mejoran los comandos bin/guarani pro_solicitudes_sube y bin/guarani notif_solicitudes_sube para que cuando un alumno recupera la regularidad se le vuelva a habilitar el beneficio de Boleto Estudiantil.

Autogestión


Principales novedades técnicas

Volver

Número de versión: 3.20.1

Fecha de publicación:

Base de Datos

Diferencias con versiones anteriores

Notas de versión

  • Se agrega configuración de URL y puerto para usar Jasper, hay que regenerar el archivo instalacion/config.php.
  • Se agrega genero x en la API

API-REST Guaraní

  • Se refactoriza el código de la API REST para que reconozca personalizaciones realizadas por la universidad, en caso de tener personalizaciones en la API REST revisar la siguiente documentación.

Gestión

  • Se agrega jasper_host y jasper_port al archivo instalacion/instalacion.ini para personalizar host y puerto del servicio Jasper, respectivamente. Por defecto toma los siguientes valores:
jasper_host = "127.0.0.1"
jasper_port = "8081"

Ver documentación Configuración de Jasper.


  • Se mejora el comando bin/guarani exportar_usuarios_arai:
    • Da la opción de exportar personas con o sin email asignado.
    • Si la persona tiene varios emails se exportaran todos siguiendo el siguiente orden de importancia: Email Principal, Email Secundario y Email Institucional.
    • Permite exportar el género No Binario hacia SIU-Araí (se deben utilizar versiones de SIU-Araí Usuarios >= v3.1.6 en el caso que se necesite Sincronizar cuentas de usuarios).

Autogestión

Se agregan nuevas directivas en el archivo instalacion/config.php, se debe recrear a partir de su template (archivo instalacion/config_template.php):

  • Se agrega la directiva jasper_host para configurar la IP/URL donde se encuentre alojado el servicio Jasper, por defecto '127.0.0.1'.
  • Se agrega la directiva jasper_port para configurar el puerto donde se encuentre alojado el servicio Jasper, por defecto '8081'.

/**
 * Host donde se corre Jasper
 *  - Ejemplo: 127.0.0.1
 */

'jasper_host' => '127.0.0.1',

/**
 * Puerto donde se corre Jasper
 *  - Ejemplo: 8081
 */

'jasper_port' => '8081',

Ver documentación Configuración de Jasper.


Principales novedades técnicas

Volver

Número de versión: 3.20.0

Fecha de publicación: 22/10/2021

Base de Datos

Diferencias con versiones anteriores

Notas de versión

Actualización de tecnologías de base:

  • Se actualiza a la versión de PHP 7.4.x.

Importante: Consideraciones de migración de PHP 7.3 a 7.4

  • Se actualiza a la versión de Composer 2.x.x

Para actualizar de Composer 1 a Composer 2 ejecutar el comando composer self-update --2.

API-REST Guaraní

 ¡Nuevo esquema de versionado de API! 
Permite mantener vivas las versiones anteriores de la API Guaraní, para ello se agrega un indicador de versión a la url. El resultado es http://<url_gestion>/rest/v1/.

Es muy IMPORTANTE que al actualizar el módulo de Gestión, cambien las configuraciones de otros sistemas que consumen la API de SIU-Guaraní como SIU-Tehuelche, SIU-Sanaviron-Quilmes, SIU-Quechua y SIDCER.

Ver configuración de API REST.

Si se posee personalizaciones en la API REST ver Personalizar servicios REST.

Gestión

  • Se migró de la versión 3.3.14 de SIU-Toba a la versión 3.3.20.

Para más información ver documentación aquí.

Autogestión

  • Se modifica el archivo de configuración config.php:

Se agregan nuevas directivas en el archivo instalacion/config.php, se debe recrear a partir de su template (archivo instalacion/config_template.php):

  • Se agrega la directiva huarpe_url_bandeja para configurar la URL de la bandeja de documentos pendientes de autorización de SIU-Huarpe.

  • Se migró de la versión 2.3.0 de Chulupí a la versión 2.4.0.